Skocz do zawartości
Krzysztof Nowak

Sourcebans problem

Rekomendowane odpowiedzi

Hey, podczas instalacji sourcebansa po stronie WWW napotkałem problem mianowicie przy tabeli "XML Support" mam disable przez co nie moge go zainstalowac ;/

Szukałem w internetach i nie mogę za cholercie nic znaleźć instalowałem pakiet php-xml, restartowałem apache ale nic to nie dało.

System: Debian 9

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Na jakim hoście masz vps?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
2 godziny temu, Scorpion Flail napisał:

Jakiej wersji php używasz? (sprawdź zarówno przez phpinfo() jak i php -v)

 

5.6.36-1+0~20180505045928.13+STRETCH~1.GBP9B5CAB

Taką wypluwa informacja w instalacji sourcebansa, i jest ona na zielono czyli pasuje.

Edytowane przez Krzysztof Nowak

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Deb9 standardowo ma w repo php7, więc musiałeś samodzielne robić downgrade. W takiej sytuacji musisz wskazywać konkretne wersje modułów przy instalacji. Spróbuj:

apt-get install php5.6-xml

Jak nie pójdzie, to spróbuj znaleźć nazwę w:

apt-cache search php | grep -i xml

Jeśli po instalacji sam restart serwera www (apache/nginx) nie wystarczy, to dopisz nazwę modułu w odpowiednim miejscu w pliku php.ini.

  • Like 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
15 godzin temu, Scorpion Flail napisał:

Deb9 standardowo ma w repo php7, więc musiałeś samodzielne robić downgrade. W takiej sytuacji musisz wskazywać konkretne wersje modułów przy instalacji. Spróbuj:

apt-get install php5.6-xml

Jak nie pójdzie, to spróbuj znaleźć nazwę w:

apt-cache search php | grep -i xml

Jeśli po instalacji sam restart serwera www (apache/nginx) nie wystarczy, to dopisz nazwę modułu w odpowiednim miejscu w pliku php.ini.


Faktycznie nie pomyślałem, domyslne pakiety php dla debiana 9 to właśnie php7, ale żeby działał mi amxbans musiałem przerzucić się na php5.6, i gdy wpisałem apt-get install php-xml pobrało mi dla php7.0, po pobraniu odpowiedniej wersji i zrestartowaniu apache wszystko śmiga :D

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

  • Podobna zawartość

    • Przez NarVo
      Nikt nie może dołączyć do mojego serwera w CS:GO postawionego na vps. Porty przekierowałem, zaporę skonfigurowałem, token ustawiłem, hibernowanie wyłączyłem. Z poziomu konsoli (chyba) wszystko wygląda dobrze. Gdy jednak ktokolwiek próbuje wejść na serwer to spotyka się z dosłownym brakiem reakcji ze strony serwera. W konsoli nie wyświetla się nawet standardowy komunikat o dołączaniu. Próbowałem reinstalla, innej komendy startowej [ktoś na steam forums pisał, że mu pomogło] i nic nie pomogło. Co mogę zrobić?
       
      Console Logs:
       
    • Przez WhiteBlue
      Cześć. Mam pewien problem otóż zainstalowałem shavit'a plugin bhoptimer. Niestety ale po zainstalowaniu i skonfigurowaniu bazy danych nie mogę wejść na serwer ładuje się do połowy i widzę w konsoli że serwer cały czas restartuje. Tabelki do tego pluginu się utworzyły w bazie danych ale nie mogę sobie poradzić z tym błędem. W logach zero błędów. Najnowsza wersja sourcemoda i metamoda. Proszę o pomoc. Wszystko wgrałem jak należy.
       

    • Przez Frosty
      Ogólnie mam problem z tym że na mapach z deathrunem po respawnie mapa zabija odrazu i nwm o co chodzi więc jak by był ktoś tak miły i mógł  mi pomóc
×