Skocz do zawartości
Krzysztof Nowak

Sourcebans problem

Rekomendowane odpowiedzi

Hey, podczas instalacji sourcebansa po stronie WWW napotkałem problem mianowicie przy tabeli "XML Support" mam disable przez co nie moge go zainstalowac ;/

Szukałem w internetach i nie mogę za cholercie nic znaleźć instalowałem pakiet php-xml, restartowałem apache ale nic to nie dało.

System: Debian 9

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Na jakim hoście masz vps?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
56 minut temu, zorix napisał:

Na jakim hoście masz vps?

 

Nie wiem jaki to ma związek z tym ale nazwa.pl

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jakiej wersji php używasz? (sprawdź zarówno przez phpinfo() jak i php -v)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Napisano (edytowane)
2 godziny temu, Scorpion Flail napisał:

Jakiej wersji php używasz? (sprawdź zarówno przez phpinfo() jak i php -v)

 

5.6.36-1+0~20180505045928.13+STRETCH~1.GBP9B5CAB

Taką wypluwa informacja w instalacji sourcebansa, i jest ona na zielono czyli pasuje.

Edytowane przez Krzysztof Nowak

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Deb9 standardowo ma w repo php7, więc musiałeś samodzielne robić downgrade. W takiej sytuacji musisz wskazywać konkretne wersje modułów przy instalacji. Spróbuj:

apt-get install php5.6-xml

Jak nie pójdzie, to spróbuj znaleźć nazwę w:

apt-cache search php | grep -i xml

Jeśli po instalacji sam restart serwera www (apache/nginx) nie wystarczy, to dopisz nazwę modułu w odpowiednim miejscu w pliku php.ini.

  • Like 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
15 godzin temu, Scorpion Flail napisał:

Deb9 standardowo ma w repo php7, więc musiałeś samodzielne robić downgrade. W takiej sytuacji musisz wskazywać konkretne wersje modułów przy instalacji. Spróbuj:

apt-get install php5.6-xml

Jak nie pójdzie, to spróbuj znaleźć nazwę w:

apt-cache search php | grep -i xml

Jeśli po instalacji sam restart serwera www (apache/nginx) nie wystarczy, to dopisz nazwę modułu w odpowiednim miejscu w pliku php.ini.


Faktycznie nie pomyślałem, domyslne pakiety php dla debiana 9 to właśnie php7, ale żeby działał mi amxbans musiałem przerzucić się na php5.6, i gdy wpisałem apt-get install php-xml pobrało mi dla php7.0, po pobraniu odpowiedniej wersji i zrestartowaniu apache wszystko śmiga :D

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

  • Podobna zawartość

    • Przez Dexe
      Witam, mam problem, ponieważ nie wiem jak usunąć dodać kredyty z tego pluginu: https://forums.alliedmods.net/showthread.php?t=276677
    • Przez Bezimienny
      Siemka, miał ktoś z was taki problem?
      Exception reported: Native is not bound
      L 09/08/2018 - 15:37:00: [SM] Blaming: shavit-hud.smx
      Dziś tak z dupy zaczął wyskakiwać. 
    • Przez bombels
      Witam mam taki problem, że co jakis czas minimalizuje mi się gra nie wiem co zrobic 
    • Przez blakker
      Siemka,
      Namieszalem a zarazem sam sie zamieszalem z instalacja sourcebans. Serwer stoi na hostingu pukawki, a baza danych jest z hostingu www.
      https://justpaste.it/62z5x
       
      Tak wyglada moj plik databases.cfg. ktore sa zbedne a ktore potrzebne? Kto wytlumaczy zielonemu ;
    • Przez Remixy Reupload
      Co zrobic zeby ta funkcja mogla sie wywolac tylko jeden raz na runde ?
×