Skocz do zawartości
Krzysztof Nowak

Sourcebans problem

Rekomendowane odpowiedzi

Hey, podczas instalacji sourcebansa po stronie WWW napotkałem problem mianowicie przy tabeli "XML Support" mam disable przez co nie moge go zainstalowac ;/

Szukałem w internetach i nie mogę za cholercie nic znaleźć instalowałem pakiet php-xml, restartowałem apache ale nic to nie dało.

System: Debian 9

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Na jakim hoście masz vps?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
56 minut temu, zorix napisał:

Na jakim hoście masz vps?

 

Nie wiem jaki to ma związek z tym ale nazwa.pl

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jakiej wersji php używasz? (sprawdź zarówno przez phpinfo() jak i php -v)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Napisano (edytowane)
2 godziny temu, Scorpion Flail napisał:

Jakiej wersji php używasz? (sprawdź zarówno przez phpinfo() jak i php -v)

 

5.6.36-1+0~20180505045928.13+STRETCH~1.GBP9B5CAB

Taką wypluwa informacja w instalacji sourcebansa, i jest ona na zielono czyli pasuje.

Edytowane przez Krzysztof Nowak

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Deb9 standardowo ma w repo php7, więc musiałeś samodzielne robić downgrade. W takiej sytuacji musisz wskazywać konkretne wersje modułów przy instalacji. Spróbuj:

apt-get install php5.6-xml

Jak nie pójdzie, to spróbuj znaleźć nazwę w:

apt-cache search php | grep -i xml

Jeśli po instalacji sam restart serwera www (apache/nginx) nie wystarczy, to dopisz nazwę modułu w odpowiednim miejscu w pliku php.ini.

  • Like 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
15 godzin temu, Scorpion Flail napisał:

Deb9 standardowo ma w repo php7, więc musiałeś samodzielne robić downgrade. W takiej sytuacji musisz wskazywać konkretne wersje modułów przy instalacji. Spróbuj:

apt-get install php5.6-xml

Jak nie pójdzie, to spróbuj znaleźć nazwę w:

apt-cache search php | grep -i xml

Jeśli po instalacji sam restart serwera www (apache/nginx) nie wystarczy, to dopisz nazwę modułu w odpowiednim miejscu w pliku php.ini.


Faktycznie nie pomyślałem, domyslne pakiety php dla debiana 9 to właśnie php7, ale żeby działał mi amxbans musiałem przerzucić się na php5.6, i gdy wpisałem apt-get install php-xml pobrało mi dla php7.0, po pobraniu odpowiedniej wersji i zrestartowaniu apache wszystko śmiga :D

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

  • Podobna zawartość

    • Przez pupcialupcia123
      Witam mam pytanie ponieważ od jakiegoś czasu mam to:
      https://i.imgur.com/ruIVtdL.png
      a dokładniej podswietlanie broni jak gracz upusci i nie wiem jak to wyłączyć
    • Przez g
      Witam mam problem po update, mapa zamiast się zmieniać przeładowuję się i jest ciągle ta sama komendy, które mam wpisane:
      mp_match_end_restart 1
      mp_match_end_changelevel 1
       
      Coś nie tak z tym?
    • Przez Mateusz Gągało
      Czołem, aktualnie tworzę w 100% zmodyfikowaną mapę do GTA SAN ANDREAS która przenosi nas w świat post-apo.
      Pojawił się pewien problem polegający na tym że przedmioty, budynki, drzewa itp nie renderują się tak szybko jak wcześniej postawione już przedmioty przez rockstar.
      Najbardziej jest to zauważalne podczas bardzo szybkiej jazdy, gdy przedmioty postawione przeze mnie respią się praktycznie przed maską jadącego auta - normalnie nie uważałem tego za problem ponieważ aut szybko jadących nie będzie tak samo jak i zbytniej możliwości na szybkie poruszanie się poprzez wcześniej wspomniany całkowicie zdewastowany świat jednak piszę ponieważ obiekty naturalne głównie drzewa, są widoczne tylko gdy podejdę do nich na bliską odległość co uniemożliwia mi praktycznie robienie lasów i stawiania drzew. Po prostu ich nie widać, pojawiają się dopiero gdy jesteśmy kilkanaście kroków obok.. Lokacje które tworze cierpią na tym ponieważ często są otoczone drzewami które widać dopiero po podejściu blisko ( pozostałe obiekty widać ) podsumowując sformułuję pytanie - "co zrobić by obiekty postawione w MTA były widoczne z daleka - tak samo jak przedmioty postawione przez rockstar.
       
      Oto przykładowy scren jednej z wielu wielu lokacji w której naocznie widać problem. W miejscu czerwonych kresek powinny być drzewa odzielające lokacje od pozostałych terenów - drzew jednak nie widać z daleka a rzeczy zbudowane przez rockstar już tak.
       
       

    • Przez Kuba Majewski
      Witam, otóż mam taki problem, że mam wgrany plugin na prefiksy (ten klanowy) i vipa hanys, co rundę w tabeli zmienia ten przedrostek z [Wlasciciel] na [VIP]. Czy da sie skonfigurować to tak zeby nie było problemow?
       
      I czy da sie zrobić tak żeby na sayu był ten przedrostek + jakiś kolor nicku? 
×