Jump to content
Sign in to follow this  
Krzysztof Nowak

Sourcebans problem

Recommended Posts

Hey, podczas instalacji sourcebansa po stronie WWW napotkałem problem mianowicie przy tabeli "XML Support" mam disable przez co nie moge go zainstalowac ;/

Szukałem w internetach i nie mogę za cholercie nic znaleźć instalowałem pakiet php-xml, restartowałem apache ale nic to nie dało.

System: Debian 9

Share this post


Link to post
Share on other sites
2 godziny temu, Scorpion Flail napisał:

Jakiej wersji php używasz? (sprawdź zarówno przez phpinfo() jak i php -v)

 

5.6.36-1+0~20180505045928.13+STRETCH~1.GBP9B5CAB

Taką wypluwa informacja w instalacji sourcebansa, i jest ona na zielono czyli pasuje.

Edited by Krzysztof Nowak

Share this post


Link to post
Share on other sites

Deb9 standardowo ma w repo php7, więc musiałeś samodzielne robić downgrade. W takiej sytuacji musisz wskazywać konkretne wersje modułów przy instalacji. Spróbuj:

apt-get install php5.6-xml

Jak nie pójdzie, to spróbuj znaleźć nazwę w:

apt-cache search php | grep -i xml

Jeśli po instalacji sam restart serwera www (apache/nginx) nie wystarczy, to dopisz nazwę modułu w odpowiednim miejscu w pliku php.ini.

  • Like 1

Share this post


Link to post
Share on other sites
15 godzin temu, Scorpion Flail napisał:

Deb9 standardowo ma w repo php7, więc musiałeś samodzielne robić downgrade. W takiej sytuacji musisz wskazywać konkretne wersje modułów przy instalacji. Spróbuj:

apt-get install php5.6-xml

Jak nie pójdzie, to spróbuj znaleźć nazwę w:

apt-cache search php | grep -i xml

Jeśli po instalacji sam restart serwera www (apache/nginx) nie wystarczy, to dopisz nazwę modułu w odpowiednim miejscu w pliku php.ini.


Faktycznie nie pomyślałem, domyslne pakiety php dla debiana 9 to właśnie php7, ale żeby działał mi amxbans musiałem przerzucić się na php5.6, i gdy wpisałem apt-get install php-xml pobrało mi dla php7.0, po pobraniu odpowiedniej wersji i zrestartowaniu apache wszystko śmiga :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By KsiadzPatulak
      Co w tym pluginie jest nie tak? Ustawione jest że po rozegranym challengu trzeba przeczekać 3 rundy lecz zamiast 3 rund czeka się tylko 2 😕 Nie ważne ile rund by się ustawiło w cvarze.
       
    • By KsiadzPatulak
      Witam posiadam serwer na liveserver i aktywowany sourceTV wszystko niby działa, demka się nagrywają lecz pojawiają się w głównym folderze i w ogóle ich nie widać na stronce : https://liveserver.pl/hltv.php?server_id=12130
    • By xewer
      Witam mam pewien problem z tym pluginem: https://forums.alliedmods.net/showthread.php?t=276677.
      Otóż wygląda to tak że żadnych errorów nie ma do tego a jest takie coś, że niektórzy nie mogą wbić na serwer gdy jest właśnie wgrany ten plugin bez żadnym dodatków czyli skinów graczy itp (to co jest do pobrania przy pluginie).
      Jak nie może wbić? Wbija ktoś  na serwer wszystko mu się pobiera fastdll jest włączone i gdy jest już inicjowanie to robi się czarny ekran i wywala cs:go.
    • By HEADSHOT
      Cześć, wgrałem ostatnio sourcebansa. Instalacja na stronie przebiegła pomyślnie, pliki na serwer wgrałem. Dodałem ID serwera w sourcebans.cfg jednak gdy dam komuś bana na serwie to ban się nie zapisuje na stronie. Wyskakuje błąd: L 04/10/2019 - 22:15:02: [sbpp_comms.smx] Connecting to database failed: [1045]: Access denied for user 'simplycs_admin'@'i14.liveserver.pl' (using password: YES). W database.cfg zamiast localhost dałem IP serwera i dodałem to IP do bazy danych jednak nadal jest ten błąd. Miał ktoś podobny problem lub zna rozwiązanie?
×