Jump to content
Sign in to follow this  
reyoshh

Problem z kompilacją SM:RPG.

Recommended Posts

Cześć, otóż mam problem z kompilacją plików upgrades z pluginu SM:RPG

Quote

 

# from smlib travis tests
SMPATTERN="http:.*sourcemod-.*-linux\..*"
SMURL="http://www.sourcemod.net/smdrop/$SMVERSION/"
SMPACKAGE=`lynx -dump "$SMURL" | egrep -o "$SMPATTERN" | tail -1`

# get sourcemod package and copy plugin code into scripting folder
if [ ! -d "build" ]; then
        mkdir build
        cd build
        wget $SMPACKAGE
        tar -xzf $(basename "$SMPACKAGE")
        rm addons/sourcemod/scripting/*.sp
        cp -R ../scripting/ addons/sourcemod/

        # get dependency libraries.
        git clone https://github.com/bcserv/smlib.git
        cp -R smlib/scripting/include/ addons/sourcemod/scripting/

        git clone https://github.com/Impact123/AutoExecConfig.git
        cp AutoExecConfig/autoexecconfig.inc addons/sourcemod/scripting/include/

        hg clone https://bitbucket.org/Drifter321/dhooks2
        cp dhooks2/sourcemod/scripting/include/dhooks.inc addons/sourcemod/scripting/include/

        git clone https://github.com/Drixevel/Chat-Processor.git
        cp Chat-Processor/scripting/include/chat-processor.inc addons/sourcemod/scripting/include/

        git clone https://bitbucket.org/minimoney1/simple-chat-processor.git
        cp simple-chat-processor/scripting/include/scp.inc addons/sourcemod/scripting/include/

        git clone https://github.com/KissLick/ColorVariables.git
        cp ColorVariables/addons/sourcemod/scripting/includes/colorvariables.inc addons/sourcemod/scripting/include/

        cd ..
fi

# setup the auto version file to have the git revision in the version convar.
# get the correct revision count
# https://github.com/travis-ci/travis-ci/issues/3412
git fetch --unshallow
fatal: --unshallow on a complete repository does not make sense

 

Wszystkie potrzebne rzeczy mam zainstalowane.

Share this post


Link to post
Share on other sites

git fetch --unshallow -- git fetch --depth=10000

Share this post


Link to post
Share on other sites
7 hours ago, daffik said:

git fetch --unshallow -- git fetch --depth=10000

fatal: --unshallow on a complete repository does not make sense

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By TerroR
      Witam mam problem z odpaleniem gothica 2 noc kruka, dzis kupiłem sobie, elegencko, a jak chciałem go włączyć to wyskakuje takie okienko https://imgur.com/a/d9dqkQV Patrzyłem poradniki to nie pomagały, albo były już stare i linki powygasały. Jeżeli macie jakis pomysł, by mi pomóc to z góry dzięki. Dodam, że mam windowsa 8.1 
    • By HEADSHOT
      Siema nie działa mi plugin na reklamy 😕
      logi:
      [SM] Exception reported: [SA3] 'EN' translation missing in message "2" L 05/22/2019 - 00:00:27: [SM] Blaming: ServerAdvertisements3.smx L 05/22/2019 - 00:00:27: [SM] Call stack trace: L 05/22/2019 - 00:00:27: [SM] [0] SetFailState L 05/22/2019 - 00:00:27: [SM] [1] Line 55, D:\Sourcemod\ServerAdvertisements3\files/misc.sp::AddMessagesToArray L 05/22/2019 - 00:00:27: [SM] [2] Line 451, D:\Sourcemod\ServerAdvertisements3\ServerAdvertisements3.sp::LoadMessages L 05/22/2019 - 00:00:27: [SM] [3] Line 366, D:\Sourcemod\ServerAdvertisements3\ServerAdvertisements3.sp::LoadConfig L 05/22/2019 - 00:00:27: [SM] [4] Line 59, D:\Sourcemod\ServerAdvertisements3\ServerAdvertisements3.sp::OnMapStart
       
    • By kenoxx
      Witam postawiłem sobie serwer csgo na vps, zainstalowałem sourcemoda oraz metamoda. Przy pierwszym uruchomieniu serwer załadował się poprawnie ale już za kolejnym razem nie mogę wbić na niego w ogóle mi się nie ładuje w grze. By móc włączyć go drugi raz muszę zrestartować całego vps's. Proszę o pomoc!
    • By jojo20012
      Witam mam plugin rankme i chciałem połączyć plugin z MySQL lecz niestety nie potrafię czy ktoś może mi pomóc bo nie wiem co gdzie jak zrobić jestem laikiem jeżeli chodzi oto 😞
×
×
  • Create New...